Les sites sous PHP 5.6 ou 7.0 en danger 12/2018

Newsletter

De nombreux sites (dont 57,1% des sites WordPress) sont développés avec le langage PHP 5.6 ou 7.0. Ces derniers ne disposeront plus de mises à jour de sécurité dès Décembre 2018.

Cela pourrait signifier une perte du trafic et une baisse significative des positions pour les sites utilisant ces vieilles versions de PHP.

Qu’est-ce que PHP ?

PHP est un langage de script qui permet la création de sites internet. Il y a différentes versions. Chaque version représente une évolution de la version précédente. Lors de la sortie d’une nouvelle version, les logiciels comme WordPress sont mis à jour pour bénéficier des nouveaux avantages.

Quand est-ce que les mises à jour de sécurité prennent fin ?

– Les mises à jour de sécurité pour PHP 5.6 s’arrêtent au 31 Décembre 2018.
– Les mises à jour et les patchs de sécurité pour PHP 7.0 s’arrêtent au 3 Décembre 2018.

Combien de sites sont en danger ?

Les sites développés avec PHP 5.6 ou PHP 7.0 sont en danger. WordPress, Magento… du moment où les versions concernées sont utilisées pour développer un site, ce dernier court des risques.

Pourquoi est-ce que le support de ces versions s’arrête ?

Le support de sécurité pour chaque version est programmé pour durer quelques années, jusqu’à ce que la version arrive en fin de vie (End Of Life). Une fois ce point atteint, il n’y aura plus aucune évolution, même si une faille est découverte. Ainsi, tous les sites sont appelés à mettre à jour la dernière version. Dans le cas contraire, il y a davantage de risques de se faire pirater.

Que se passe-t-il si vous n’arrivez pas à mettre à jour PHP ?

Tous les sites pas mis à jour seront vulnérables et non sécurisés. De plus, de nombreuses extensions, des thèmes ou même le CMS en question pourrait arrêter de fonctionner.

Faites appel à votre webmaster ou votre agence pour vous mettre rapidement à jour.

Source : Search Engine Journal – Roger Montti